Page 1 of 1

How to disable libraries' "welcome" messages?

PostPosted: Sun Dec 11, 2016 2:12 pm
by anaumov
Hello,

I would like to know how to disable output of libraries' messages that SBCL shows in time of including/require these. For example, after I (require :snmp), I get this message:

Code: Select all

;;; ------------------------------------------------------------------------
;;;  Portable Threads Interface 2.3
;;;
;;;    Developed and supported by the GBBopen Project (http:/GBBopen.org/)
;;;    (See http://GBBopen.org/downloads/LICENSE for license details.)
;;; ------------------------------------------------------------------------



I want to see output of my format functions ONLY. Output of my script is an input for another system. So, I don't want to use "grep" or something like this between.
Now should use this
Code: Select all
./my_script.cl | grep -v ";"


Thank you.

Re: How to disable libraries' "welcome" messages?

PostPosted: Sun Dec 11, 2016 3:54 pm
by David Mullen
The welcome-message thing with portable-threads is mentioned here—that author's version of portable-threads has killed the message. Aside from changing the library code, you could just muzzle standard output like this:

Code: Select all
(let ((*standard-output* (make-broadcast-stream)))
  (require :snmp))

Re: How to disable libraries' "welcome" messages?

PostPosted: Mon Dec 12, 2016 2:55 am
by anaumov
Thank you! Yes, it fix my problem.