lisp and oracle

You have problems, and we're glad to hear them. Explain the problem, what you have tried, and where you got stuck.
Feel free to share a little info on yourself and the course.
Forum rules
Please respect your teacher's guidelines. Homework is a learning tool. If we just post answers, we aren't actually helping. When you post questions, be sure to show what you have tried or what you don't understand.

lisp and oracle

Postby ruben.vanveerdeghem » Fri Mar 18, 2016 8:34 am

I already have experience in lisp programs used by cocreate modeling, but this is not able to connect to a oracle database, so I'm trying to do this by clisp, sbcl, lispworks personal or allegro express.

I'm working on a windows computer and can't find any tutorial on how to connect any of these programs to a remote oracle database. Can somebody help me to program this from scratch?

I tried to use "clsql" by doing this:
Code: Select all
(in-package :cl-user)

(load "C:/Program Files/Steel Bank Common Lisp/1.3.3/clsql-6.7.0/asdf.lisp")
(load "C:/uffi/uffi.asd")
(push #P"/usr/share/lisp/uffi/" asdf:*central-registry*)
(push #P"/usr/share/lisp/clsql/" asdf:*central-registry*)
(asdf:operate 'asdf:load-op 'clsql)


But the last line already gives an error that clsql doesn't exist. I think I did something wrong to "install" this, but I don't know what.
Anyone who can help me and has some experience whit this?

Thank you very much in advance
ruben.vanveerdeghem
 
Posts: 2
Joined: Fri Mar 18, 2016 8:26 am

Re: lisp and oracle

Postby nuntius » Fri Mar 18, 2016 7:03 pm

Hi, you might want to give quicklisp a try.
It appears to have clsql support.
Quicklisp installs are generally easy.

https://www.quicklisp.org/beta/
User avatar
nuntius
 
Posts: 524
Joined: Sat Aug 09, 2008 10:44 am
Location: Newton, MA

Re: lisp and oracle

Postby ruben.vanveerdeghem » Sun Mar 20, 2016 1:36 am

Quicklisp did indeed help me a little further, but after installing "clsql" and "uffi" I still get some errors.

Code: Select all
* (clsql:connect '("localhost" "world" "root" "") :database-type :mysql)
STYLE-WARNING: Undefined alien: "strtoull"
STYLE-WARNING: Undefined alien: "strtoll"

debugger invoked on a UNDEFINED-FUNCTION in thread
#<THREAD "main thread" RUNNING {23EAC0D1}>:
  The function MYSQL:MYSQL-GET-CLIENT-INFO is undefined.

Type HELP for debugger help, or (SB-EXT:EXIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
  0: [RETRY                        ] Retry ASDF operation.
  1: [CLEAR-CONFIGURATION-AND-RETRY] Retry ASDF operation after resetting the
                                     configuration.
  2: [ABORT                        ] Exit debugger, returning to top level.

(SYMBOL-FUNCTION MYSQL:MYSQL-GET-CLIENT-INFO)
0]


I searched google to find a solution for this "The function MYSQL:MYSQL-GET-CLIENT-INFO is undefined."
But I can't find anything, can somebody help me with this?

Thanks
ruben.vanveerdeghem
 
Posts: 2
Joined: Fri Mar 18, 2016 8:26 am


Return to Homework

Who is online

Users browsing this forum: No registered users and 1 guest

cron