Page 1 of 1

Hunchentoot loading error

PostPosted: Thu Jan 02, 2014 1:54 am
by damienb
Hi all,

Please bear with me, I'm a noob.

I'm running SBCL through Gvim/Slimv on Windows 7.

When the laughter at my OS dies down, continue:

I'm attempting to get through this tutorial:

I've gotten quicklisp installed (how exactly, I've forgotten) and when I type:

Code: Select all
>> (ql:quickload :hunchentoot)

I get the error:

error opening #P"C:/Windows/C/quicklisp/dists/quicklisp/software/cffi_0.11.2/tests/compile.bat"

I know there's probably something fundamental I don't get yet here, such as how packages work, how quicklisp works, where/if I should have Hunchentoot on my hard drive, how/if I need to use ASDF (?), and so on, but I have yet to find much in the way of "ground-up" lisp tutorials out there, at least when it comes to writing real software that does real things. I'm not even sure which questions to ask.

Any help/resources/"duh" clarifications would be appreciated.

I'm logging off and will plan to dig into Chapter 21 of Practical Common Lisp as some bedtime reading, so maybe I'll have a better handle on things when I log in next.



Re: Hunchentoot loading error

PostPosted: Thu Jan 02, 2014 1:30 pm
by nuntius
Hi Damien,

This looks like a possible CFFI problem on Win7. You appear to be running the latest CFFI. What version of SBCL are you using?

You will probably get the best help by sending this problem report to the CFFI mailing list. To join the CFFI mailing list, send an email to Then you should get an activation email, after which you should be able to send messages.

Re: Hunchentoot loading error

PostPosted: Thu Jan 02, 2014 2:16 pm
by damienb
The top of my REPL says:
SBCL 1.1.12 Port: 4005 Pid: 976

I don't remember installing CFFI and it's not a dependency for Hunchentoot, according to .

C:\Windows\C is not a directory, though C:\quicklisp\dists\quicklisp\software is. In that folder, though, there is no cffi_anything folder. What/who is trying to open that folder and why?

I tried
Code: Select all
(asdf:load-system :hunchentoot)

and it said Component :HUNCHENTOOT not found. I'm still not entirely clear on what asdf does vs. what quicklisp does, and how/if they overlap.

Re: Hunchentoot loading error

PostPosted: Thu Jan 02, 2014 2:28 pm
by damienb
Interestingly, there doesn't seem to be an immediate problem in LispWorks. Since I'm using the Personal Edition (no init file), I type:

Code: Select all
(load "C:\\quicklisp\\setup.lisp")

Code: Select all
(ql:quickload :hunchentoot)

And the only error I get at the end says:
The following function is undefined:

So, perhaps it's a SBCL-specific problem? I'm really clueless here.